ISSUE IDENTIFIED // Cloud POS Outage - 18th January 2023
Incident Report for Citrus-Lime Service Status
Postmortem

This morning we had an unexpected outage with Cloud POS, while conducting some maintenance on the Hyper-V hosts.

The outage was around from 6:50am until approx. 7:30am.

The maintenance was to fix some packet loss issues we have been experiencing and the fix causes the network cards in the hosts to briefly disconnect for a second or so.

Unfortunately, this caused one of the Load balancer nodes for Cloud POS to disconnect and attempt to failover to the other node.

The second node was in maintenance mode at the time and therefore the cluster went down preventing access to Cloud POS.

We rebooted the primary node which fixed the problem and also removed the 2nd node from maintenance mode.

Investigations will continue, to understand why this happened and implement preventative action in the future.

Posted Jan 18, 2023 - 10:02 GMT

Resolved
We experienced an Outage with Cloud POS this morning, 18th January, at 06:50.

This was identified and fixed, and Cloud POS was operating as normal, by 07:30.

A full incident summary is available in the postmortem section of this post.
Posted Jan 18, 2023 - 06:30 GMT