MONITORING // Brief timeouts and performance issues in Cloud POS

Incident Report for Citrus-Lime Service Status

Resolved

The platform has remained stable, and maintenance has concluded for the day. This issue is marked as resolved.

Thank you for your patience whilst we worked to restore services this morning.
Posted Aug 26, 2026 - 10:45 BST

Monitoring

We are aware of an issue which affected Cloud POS, Workshop & Back Office this morning at approximately 10:08-10:12am (BST).

Whilst this issue was live, the affected pages were performing slowly and producing timeouts.

This was an unforeseen side effect of our ongoing infrastructure maintenance, rather than an issue with the platform.

The platform is now stable, and we are closely monitoring performance to ensure the issue has been fully resolved.
Posted Aug 26, 2026 - 10:26 BST
This incident affected: Cloud POS.