ISSUE IDENTIFIED // Cloud Reports Outage

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 08:40 BST

Monitoring

Hello,

We are aware of an issue whereby Cloud Reports became temporarily unavailable at approximately 10:40am (UK Time) this morning.

We have taken steps to remedy this, and Reports is now available again.

We will continue to monitor this closely throughout the rest of the day.
Posted Jul 09, 2025 - 10:49 BST
This incident affected: Cloud Reports.