ISSUE IDENTIFIED // Cloud Reports Loading Delays

Incident Report for Citrus-Lime Service Status

Resolved

This issue has now been resolved and performance has remained consistent.
Posted Jun 11, 2025 - 10:22 BST

Monitoring

Changes have been implemented to address the loading times of Cloud Reports.

We will continue to monitor the performance of this module and act accordingly.
Posted Jun 10, 2025 - 13:05 BST

Identified

Please be advised that we are experiencing issues with the loading speeds of the Cloud Reports Module.

Users may experience:
- Longer loading times in the Cloud Reports Module
- Errors due to reports timing out

This issue is not specific to one report.

Our team our working on this issue as a priority and further updates will be provided in due course.
Posted Jun 10, 2025 - 12:22 BST
This incident affected: Cloud Reports.