ISSUE IDENTIFIED // Errors when tendering Web Orders / using Customer Rewards in POS

Incident Report for Citrus-Lime Service Status

Resolved

Summary

An issue occurred as a result of a global AWS service disruption that affected internet services worldwide. This outage impacted one of our connected third-party services, which relies on AWS infrastructure. The degraded performance of that service caused a knock-on effect on specific areas within our own platform, leading to slower response times and intermittent issues for some users.

Root Cause

The root cause was identified as the degraded performance of one service hosted on AWS. As AWS experienced widespread outages, this service became significantly slower to respond, creating delays that propagated through our systems and affected some platform performance due to bottlenecked requests.

Resolution

The incident was resolved once AWS restored normal operations globally. Our systems automatically recovered as the service regained normal performance levels.

Next Steps / Preventive Measures

We are actively working to enhance our platform’s fault tolerance and reduce dependency risks associated with third-party service disruptions such as this.

Conclusion

The incident stemmed from a global AWS service disruption, which has now been resolved.
We appreciate your patience and cooperation as we worked to restore normal service and are committed to strengthening our platform to prevent similar issues in the future.
Posted Oct 20, 2025 - 16:49 BST

Investigating

Hello,

We are working to resolve an issue whereby tendering Web Orders in POS is slow, and/or producing an error. Retailers may also experience slowness when trying to use Customer Rewards in POS, or for any other transaction which calls out to eCommerce/other modules.

We have identified the cause of this issue, and we are working to implement a fix as soon as possible.
Posted Oct 20, 2025 - 10:19 BST
This incident affected: Cloud POS and Customer Rewards.