Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2025 - 06:00 BST
Scheduled
We will be performing scheduled infrastructure updates on a section of our servers during the early hours on Tuesday 10th June 2025.
Maintenance Window: Between 06:00 and 07:30 AM (BST) on 10/06/2025 Expected Downtime: 2 to 30 minutes (intermittent or continuous)
These updates are part of our ongoing commitment to maintain & improve the stability, performance, and security of your website infrastructure. While we aim to keep any disruption to a minimum, your website may be temporarily unavailable during this time.
No action is required on your part. We will monitor the process closely, and your site should come back up automatically once complete.
If you have any questions or concerns, please don’t hesitate to reach out to the Support Team.
Posted Jun 06, 2025 - 17:26 BST
This scheduled maintenance affected: eCommerce Platform - Standard and eCommerce Platform - Premium.