ISSUE IDENTIFIED // Email Delivery Issues - 1st July 2026

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 16:02 BST

Monitoring

Between approximately 010:40 and 11:00 BST today, some outbound emails from our platform - including order confirmations, receipts and notifications - may have been delayed or delivered later than usual.

This was caused by an issue with our email delivery provider. They've identified the cause and applied a fix, and delivery is now back to normal. We're keeping an eye on things to make sure it stays that way.

No action is needed on your end. If you're still seeing delays with a specific email after 11:30 BST, please get in touch with our Support Team.
Posted Jul 01, 2026 - 11:13 BST