A hotpatch has been deployed to resolve this issue.
Testing has been verified and a successful payment link has been generated.
If you have any further issues, please do not hesitate to contact our Support Team, either via Live Chat or Phone.
Posted Jan 19, 2026 - 13:17 GMT
Identified
We have identified the cause of this issue and have prepared a fix.
We intend to deploy this fix at 1pm today (GMT).
Following the update, Payment Link functionality should be restored for retailers using Cloud POS.
Posted Jan 19, 2026 - 12:31 GMT
Investigating
We are currently working to resolve an issue which is preventing retailers from creating CitrusPay Payment Links in POS.
Retailers are currently unable to generate links to send to customers, with POS producing the following error instead: 'We encountered an error when creating the payment link. Please contact Citrus-Lime for support.'
This is being treated as a high priority, and further updates will be provided here as soon as possible.