ISSUE IDENTIFIED // Timeout errors in the Workshop Module

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted May 06, 2026 - 13:52 BST

Monitoring

A fix has been applied and is actively being monitored.

Preliminary results suggest the issue has been resolved; however, we will continue to track performance to validate stability.
Posted May 06, 2026 - 12:57 BST

Investigating

We are currently investigating an issue affecting the Workshop Module which is causing timeout errors when attempting to edit an existing job.

Further information will be provided in due course.
Posted May 06, 2026 - 12:27 BST
This incident affected: Cloud POS.