ISSUE IDENTIFIED // Email Delivery Network Issues (third party)

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 08:34 GMT

Identified

Hello,

Our third-party provider for email despatch is reporting a network issue on their Status Page, noting that email delivery is currently impacted.

This may mean some Cloud POS / eCommerce customer emails are not delivered when sent from the platform.

We will keep a close eye on the situation with the provider, and will confirm when this is resolved.
Posted Mar 02, 2026 - 17:04 GMT