ISSUE IDENTIFIED // Some emails are not being successfully sent

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Feb 27, 2026 - 08:50 GMT

Monitoring

We’re currently aware of a global issue affecting emails sent to Microsoft-hosted domains (including hotmail.com, outlook.com, live.com and others).

Impacted emails may show as “Processed” in Reports > Activity, but delivery attempts are receiving 'temporary issues' response statuses.

This is a Microsoft-wide issue that’s affecting multiple email providers, not just us. We’re keeping a close eye on the situation and monitoring updates while Microsoft works on a fix.

Thank you for your patience — we’ll share further updates as soon as we have them.
Posted Feb 26, 2026 - 11:39 GMT