ISSUE IDENTIFIED // Brief outage to multiple services due to internal system issue

Incident Report for Citrus-Lime Service Status

Resolved

Our platform experienced a brief period of downtime today at 13:55 (UK Time) due to an internal systems issue.

This outage affected Cloud POS, Back Office, Cloud MT, and other Citrus-Lime services which were unavailable for approximately 3-5 minutes.

The platform is now stable, and we are working hard to prevent future incidents of this kind.

Thank you for your patience and understanding.
Posted Mar 26, 2025 - 13:55 GMT