ISSUE IDENTIFIED // Some Amazon Orders Failing to Download

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 13:51 BST

Update

We are continuing to investigate this issue.
Posted Jul 28, 2026 - 10:56 BST

Investigating

We are currently investigating an issue preventing some Amazon orders from downloading to POS.

Our team is actively working to identify the cause and restore service as quickly as possible.

We will provide further updates here as soon as more information becomes available.
Posted Jul 28, 2026 - 10:54 BST
This incident affected: eCommerce Platform - Standard and eCommerce Platform - Premium.