ISSUE IDENTIFIED // Speed Issues & Website Outages 14/04/25

Incident Report for Citrus-Lime Service Status

Postmortem

On April 14th at 11:28am (UK Time), users on the Cloud POS Back Office and eCommerce platform experienced disruption in the form of speed issues and eCommerce site outages.

This prompted an immediate investigation into the cause of the issue, and we identified unusual network behavior affecting one of our hosts. To address this quickly, we took immediate steps to isolate and stabilise the environment so that performance could recover.

The platform is stable, and has remained stable since this action was taken at approximately 11:40am (UK Time).

Following this, we continued to investigate the underlying cause, including discussion with our network provider. Later that day, our network provider confirmed a fault on their side of the network, beginning at the exact time we first saw the issue here.

We are working with our provider to ensure that the network issue has been fully resolved. As a precaution, we have also taken additional steps internally to enhance resilience and monitoring, ensuring continued service stability.

We appreciate your understanding, and remain committed to delivering reliable service for users of the platform.

Posted Apr 15, 2025 - 09:29 BST

Resolved

We have resolved this issue.
Posted Apr 14, 2025 - 11:51 BST

Update

We are continuing to investigate this issue.
Posted Apr 14, 2025 - 11:39 BST

Investigating

We are working to resolve an incident whereby Citrus-Lime products such as Back Office and retailer eCommerce front end sites are facing intermittent availability issues.

This started occurring at around 11:30am (UK Time).

We are working on this as our highest priority and a further update will be provided once available.
Posted Apr 14, 2025 - 11:36 BST
This incident affected: Cloud POS, eCommerce Platform - Standard, eCommerce Platform - Premium, and Courier Integration Module.