ISSUE IDENTIFIED // Timeout Errors in Back Office - Tuesday 16th June 2026

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 11:09 BST

Monitoring

We are investigating an issue that caused some retailers to experience intermittent timeout errors in Back Office earlier this morning, including during Purchase Order creation and when loading Picklists.

The errors have now subsided, and we believe we have identified the underlying cause.

We will continue to monitor the situation and implement measures to prevent similar issues from occurring in the future.
Posted Jun 16, 2026 - 08:45 BST
This incident affected: Cloud POS.