WordPress blogs are unavailable at this time, as a side-effect to the ongoing maintenance.
We are working to restore availability as soon as possible.
Posted Jun 13, 2025 - 10:43 BST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 13, 2025 - 09:15 BST
Scheduled
We will be updating our WordPress installation at 14:30 (UK time) today.
What to expect: A brief interruption in access. No foreseen impact on your content or user data (NB, we are taking a backup under Wordpress' guidance). Normal operation will resume automatically after the update is complete.
Plugins & Themes: Reputable third-party developers are expected to maintain compatibility with the latest WordPress versions, and therefore, no disruption is anticipated. If you do experience any issues with a plugin or theme after the update, please do let us know — as we’ll do our best to help. However, the primary responsibility lies with the plugin’s third-party developer, so we also recommend contacting them directly if a plugin no longer works after the new version is installed.
Our Support and Infrastructure Teams will be on hand to monitor this update and troubleshoot any unforeseen issues.
Posted Jun 13, 2025 - 09:09 BST
This scheduled maintenance affected: eCommerce Platform - Standard and eCommerce Platform - Premium.