ISSUE IDENTIFIED // CloudPOS and Back Office Slow Downs - 4th December 2024

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.

We will post further details about the incident later today.
Posted Dec 05, 2025 - 08:34 GMT

Update

We are continuing to monitor for any further issues.
Posted Dec 04, 2025 - 14:49 GMT

Monitoring

Whilst the platform has settled and both Cloud POS and Back Office have returned to expected speeds, our team are working to understand the underlying cause.

We will continue to monitor the platform during the course of this investigation.
Posted Dec 04, 2025 - 11:24 GMT

Investigating

We are aware that users are experiencing significant slow downs in both Cloud POS and Back Office.

This is being investigated as a matter of urgency and further updates will be provided as soon as possible.
Posted Dec 04, 2025 - 11:06 GMT
This incident affected: Cloud POS.