Further monitoring shows that the Cloud Reports Module is now stable and reports are loading as expected.
If you experience any further issues, please contact our Support Team, who will be on hand to advise.
Posted Jun 10, 2025 - 10:14 BST
Monitoring
We have implemented changes to address the loading speed issues and things are looking promising.
Our teams will continue to monitor the reporting module over the next few hours.
Posted Jun 09, 2025 - 17:03 BST
Update
We are actively working to resolve the issue and are doing everything we can to fix it as quickly as possible. We appreciate your continued patience.
Posted Jun 09, 2025 - 15:21 BST
Identified
When loading a report from the module, you may experience an on-screen error caused by a time-out.
Work continues to resolve significant speed issues which have been identified within the Cloud Reports Module and further updates will be provided in due course.
Posted Jun 09, 2025 - 13:31 BST
Monitoring
We are currently experiencing issues with the loading speed of Cloud Reports. This is affecting various reports for different retailers.
A fix has been implemented and we are now monitoring the status of the reporting module to ensure that this has been successful.