MONITORING // Email Delivery Delays due to Issue with Provider - Friday 4th September

Incident Report for Citrus-Lime Service Status

Resolved

Excess server burden caused by knock on effects from the Microsoft service issue caused abnormal outbound queues.

A fix has been implemented by our service provider and resolution has been confirmed.
Posted Sep 04, 2026 - 16:40 BST

Update

Microsoft has accepted responsibility for the current email delays.

You may continue to experience delays in sending and receiving emails through the platform. Our guidance remains as below; you can use the Mail Queue Report in CloudMT to monitor incoming orders and order details.
Posted Sep 04, 2026 - 13:41 BST

Monitoring

We have received a notification from our email delivery service provider that some accounts are experiencing delays in email delivery.

This may impact the speed at which Order Confirmation emails, and other platform emails, are received by retailers and their customers.

We have been advised that the provider is investigating this issue with urgency.

We are closely monitoring the provider's status for updates, and an update will be provided here once one is available.

Retailers should be able to check for new Order Confirmations in the Mail Queue Report in CloudMT in the meantime: https://cloudmt.citruslime.com/#/mail-queue-report
Posted Sep 04, 2026 - 11:17 BST