ISSUE IDENTIFIED // Issues printing courier labels for Royal Mail & Parcelforce - 18th June 2026

Incident Report for Citrus-Lime Service Status

Resolved

This issue has now been resolved and label printing has remained stable.
Posted Jun 18, 2026 - 12:18 BST

Monitoring

We are continuing to monitor this issue.

At present, the ability to generate Courier Labels remains stable, however our third-party integration provider continues to report intermittent issues.
Posted Jun 18, 2026 - 11:17 BST

Investigating

We have been made aware of an issue affecting label printing for some of our users for Parcelforce and Royal Mail, caused by a problem with our third-party courier integration provider.

We will provide further updates as soon as we have more information.

In the meantime, we recommend generating labels directly through the Courier Portal to ensure your shipping deadlines are met.
Posted Jun 18, 2026 - 10:38 BST
This incident affected: Courier Integration Module.