ISSUE IDENTIFIED // Cloud POS Speed - 15th March 2024
Incident Report for Citrus-Lime Service Status
Resolved
We have successfully resolved an issue which was causing Cloud POS to run slowly in the following areas:

Tendering Transactions in the Point of Sale
Recalling orders

We quickly diagnosed the cause of the slowdown and are now working on implementing a change which will prevent reoccurrence of the issue.
Posted Mar 15, 2024 - 00:30 GMT