ISSUE IDENTIFIED // Google Ads Conversion Value no longer tracking

Incident Report for Citrus-Lime Service Status

Resolved

This issue has been resolved, and tracking has remained stable since the fix was implemented.
Posted May 29, 2026 - 11:36 BST

Monitoring

A fix was implemented at 11:15am (BST) today, and we are currently monitoring the results.

Early signs look positive, but we will continue to monitor for 24 hours to ensure Ads Conversion tracking is fully operational.
Posted May 28, 2026 - 14:39 BST

Identified

The issue has been identified and a fix is being implemented.
Posted May 28, 2026 - 09:56 BST

Investigating

We are currently investigating a high-priority issue affecting conversion value tracking in Google Ads.

We have observed a significant drop in tracking activity across all sites beginning at approximately 9:00 AM yesterday.

Our team is actively working to identify the root cause and restore normal tracking as quickly as possible.

We will continue to provide updates here as more information becomes available.
Posted May 28, 2026 - 08:57 BST
This incident affected: eCommerce Platform - Standard and eCommerce Platform - Premium.