ISSUE IDENTIFIED // Slow loading images across the eCommerce Platform

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Mar 28, 2025 - 13:40 GMT

Monitoring

This issue is no longer affecting platform images.

We are working to prevent the underlying cause of this issue, and we will continue to closely monitor performance throughout.
Posted Mar 28, 2025 - 11:24 GMT

Investigating

We received reports today (28th March 2025) of images slowly loading across the eCommerce Platform, affecting the loading speeds of the homepage, product pages, and results pages.

This is being investigated, and further information will be provided in due course.
Posted Mar 28, 2025 - 11:07 GMT
This incident affected: eCommerce Platform - Premium.