ISSUE IDENTIFIED // CitrusPay Payouts page not accessible

Incident Report for Citrus-Lime Service Status

Identified

We're aware that retailers cannot access the CitrusPay Payout page.

Our team has identified the cause and are working to restore service as quickly as possible.

We will provide further updates here as soon as more information becomes available.
Posted Sep 11, 2026 - 09:22 BST
This incident affects: Cloud POS.