ISSUE IDENTIFIED // Increased CitrusPay payment refusals

Incident Report for Citrus-Lime Service Status

Resolved

This issue was resolved with our Checkout Hotpatch, deployed at 15:20 (GMT).

We will continue to monitor closely to ensure the fix has been successful.
Posted Jan 22, 2026 - 15:35 GMT

Identified

Following a checkout update released on 21/01/2025 at approximately 12:30pm GMT, we have identified an increase in payment refusal rates for CitrusPay.

When customers encounter this, they are redirected back to their cart during checkout to try again. In most cases, customers are able to retry the payment and complete their purchase successfully.

Impact:
- Higher-than-normal payment refusals for CitrusPay, which show as 'Pending' in the payments page.
- Customers may need to retry checkout to complete payment.

Current actions:
We are preparing a hotpatch to resolve this issue as quickly as possible and restore normal payment behaviour.

Support:
If you would like to query specific payments or check whether any of your customers have been affected, our Support Team is available to help.

Further updates will be provided as work progresses.
Posted Jan 22, 2026 - 14:03 GMT
This incident affected: eCommerce Platform - Standard and eCommerce Platform - Premium.