ISSUE IDENTIFIED // Intermittent Site Slowdowns - Monday 1st June 2026

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 11:29 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2026 - 10:07 BST

Investigating

Hello,

We are currently investigating an intermittent issue affecting some sites on our eCommerce Platform.

Sites remain operational; however, some users may experience brief periods of increased latency or timeouts before services automatically recover.

Our initial investigation indicates that the issue may be related to infrastructure updates carried out between 6:00 AM and 8:00 AM BST this morning.

We are treating this as a high-priority incident and are working to identify and implement a resolution as quickly as possible.

Further updates will be posted here as they become available.
Posted Jun 01, 2026 - 09:14 BST
This incident affected: eCommerce Platform - Standard and eCommerce Platform - Premium.