ISSUE IDENTIFIED // Slow-downs in Back Office and Point of Sale - 31st March 2026

Incident Report for Citrus-Lime Service Status

Resolved

This issue has now been resolved; monitoring has shown a stable platform since changes were implemented yesterday afternoon.

We will continue to monitor in our standard capacity.
Posted Apr 01, 2026 - 10:24 BST

Monitoring

The Development Team have made some changes to optimise performance and we are now monitoring the platform closely.
Posted Mar 31, 2026 - 17:05 BST

Identified

We are currently experiencing issues affecting Back Office and Cloud POS.

Our development team have identified this as a priority and are actively investigating the root cause. We will provide a further update as soon as possible.
Posted Mar 31, 2026 - 15:15 BST

Update

The platform has stabilised and performance has returned to normal levels.

Our team will continue monitoring throughout the afternoon to ensure everything remains on track.
Posted Mar 31, 2026 - 14:20 BST

Monitoring

We are aware of speed issues which are intermittently affecting certain areas of the Back Office and Point of Sale including, but not limited to:
- Stock takes
- Recalling Orders
- Loading a picklist

We are actively investigating and monitoring this situation to understand the cause. Further updates will be provided in due course.
Posted Mar 31, 2026 - 12:15 BST
This incident affected: Cloud POS.