ISSUE IDENTIFIED // Payments Pending on Cloud MT Payments Page - 21st April 2026

Incident Report for Citrus-Lime Service Status

Resolved

Please be advised that this issue has now been resolved, as confirmed by Adyen.

The backlog of pending payments has now cleared and we're seeing payment statuses updating in real time.
Posted Apr 21, 2026 - 16:35 BST

Monitoring

We are aware of an issue currently affecting payment processing through Adyen. Payments are experiencing delays at the capture stage, meaning transactions are taking longer than usual to complete and may remain in a pending state for an extended period.

Adyen's Engineering team are actively investigating. We are monitoring the situation closely and will provide further updates as they become available.
Posted Apr 21, 2026 - 15:16 BST
This incident affected: Ecommerce Checkout.