ISSUE IDENTIFIED // Cloud POS, Back Office & Related Pages Slow

Incident Report for Citrus-Lime Service Status

Postmortem

POS Service Incident - Friday 3rd July 2026

Status: Resolved

Summary

On Friday 3rd July 2026, between approximately 10:29am and 10:45am BST, retailers experienced intermittent slow performance and on-screen errors when using Cloud POS.

Following recovery of the core POS service, some retailers also experienced delays when printing receipts and barcode labels. This was isolated to one production node and was fully resolved later that afternoon.

What happened

The incident caused one part of the POS platform to become unstable, resulting in service degradation and on-screen loading errors.

Whilst core POS service recovered by approximately 10:45am BST, one production node continued to experience a backlog of print requests, which resulted in intermittent receipt and barcode label printing timeouts.

Our DevOps team investigated throughout the incident, closely monitoring platform health and database activity while working to isolate the remaining issue. At 1:18pm BST we applied a direct fix, which was successful in clearing the print backlog and restoring normal service.

Resolution & Prevention

Immediate action taken during the incident restored full service on Friday. Following the incident, we carried out a detailed investigation into the events leading up to the degradation to understand and resolve the issue permanently.

The POS release scheduled for deployment tonight includes improvements in the area highlighted by our investigation. These enhancements are intended to strengthen the platform's resilience and reduce the likelihood of similar behaviour occurring in the future.

We will continue to monitor the platform following deployment to confirm the effectiveness of these improvements.

Thank you for your patience whilst we worked to resolve this incident.

Posted Jul 06, 2026 - 11:41 BST

Resolved

This incident has been resolved.
Posted Jul 03, 2026 - 16:40 BST

Update

Printing was restored at approximately 13:18 (BST).

We are continuing to monitor all services closely to ensure this incident is fully resolved.
Posted Jul 03, 2026 - 13:56 BST

Update

Point of Sale and other core modules have remained stable since approximately 10:45. We are, however, continuing to see issues affecting receipt printing and connected hardware.

Our investigation into the root cause is ongoing, and we will provide a further update as soon as more information is available.
Posted Jul 03, 2026 - 12:27 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2026 - 12:00 BST

Investigating

We are urgently investigating an issue affecting Cloud POS (pos2.citruslime.com), where users may experience very slow page performance, timeouts, and loading errors.

Our team is actively working to identify the cause and restore normal service as quickly as possible. We will provide further updates as soon as more information is available.
Posted Jul 03, 2026 - 10:34 BST
This incident affected: Cloud POS.