ISSUE IDENTIFIED // POS and Back Office slow down - 5th December 2025

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 15:47 GMT

Monitoring

We have identified the underlying cause of the Cloud POS issues experienced yesterday and today.

A fix has now been implemented, performance has stabilised, and we are monitoring the system closely. We will continue working on longer-term measures to prevent this from happening again.

Further details will be shared in due course.
Posted Dec 05, 2025 - 10:56 GMT

Identified

Hello,

Despite the work carried out yesterday, we experienced a further slowdown in Cloud POS this morning between 09:58 and 10:00 (GMT).

Our team is continuing to work on resolving this issue and preventing any future occurrences. This remains our highest priority.

Thank you for your patience while we work to bring this to a resolution.
Posted Dec 05, 2025 - 10:24 GMT
This incident affected: Cloud POS.