ISSUE IDENTIFIED // Timeouts in Back Office - Receipt Journal, Stock Takes, Orders page

Incident Report for Citrus-Lime Service Status

Resolved

This incident has been resolved.
Posted Oct 13, 2025 - 08:30 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2025 - 20:47 BST

Update

We are implementing a fix to this issue shortly - close monitoring will be undertaken following the deployment to ensure the issue is resolved.
Posted Oct 09, 2025 - 15:43 BST

Identified

Work continues on this issue.
Posted Oct 09, 2025 - 14:37 BST

Investigating

We are working to resolve an issue whereby retailers are seeing timeout errors when trying to use large pages in the Back Office, such as:

- Receipt Journal
- Stock Takes
- Customer Orders page (All Orders)

We are working to resolve this as our highest priority, and a further update will be provided as soon as possible.
Posted Oct 09, 2025 - 12:58 BST
This incident affected: Cloud POS.