ISSUE IDENTIFIED // On-screen Errors Whilst using CloudPOS
Incident Report for Citrus-Lime Service Status
Resolved
We will continue to monitor any errors received across the platform, and will take action where necessary.

If you experience any lasting issues which cannot be resolved by a refresh, or errors which flag repeatedly, please contact the Support Team via Live Chat or telephone.
Posted Mar 20, 2024 - 14:01 GMT
Investigating
We are currently aware of an issue whereby retailers are facing on-screen errors whilst using various functions in CloudPOS this morning.

Each report we have received about these errors indicates that they can be resolved by refreshing the browser page, and that retailers should be able to continue using POS after doing so.

If you experience any lasting issues which cannot be resolved by a refresh, or have any other questions about the above, please contact the Support Team via Live Chat or telephone.
Posted Mar 20, 2024 - 09:30 GMT
This incident affected: Cloud POS.