ISSUE IDENTIFIED // Pending Payments on the Payments Page - 14th February 2026

Incident Report for Citrus-Lime Service Status

Resolved

Our Development Team quickly identified the cause of this issue and has implemented a fix.

The issue is now resolved.
Posted Feb 14, 2026 - 18:15 GMT

Investigating

We are currently investigating reports of a number of pending payments which can be seen on the CloudMT Payments Page.

Further updates to follow.
Posted Feb 14, 2026 - 17:12 GMT
This incident affected: Ecommerce Checkout.