We will provide a full incident summary in due course.
Posted Jul 16, 2026 - 16:35 BST
Monitoring
All services have now been restored.
We will closely monitor the situation to ensure things remain stable.
Posted Jul 15, 2026 - 15:55 BST
Update
We are in the process of restoring the affected websites with other services to follow.
Posted Jul 15, 2026 - 15:45 BST
Update
POS, Back Office and Workshop are now restored.
Other services and eCommerce websites will be restored as soon as possible.
Posted Jul 15, 2026 - 15:20 BST
Identified
The root cause of the issue has been identified and a fix is being implemented as soon as possible.
Posted Jul 15, 2026 - 15:13 BST
Investigating
We have been made aware of an issue which is affecting the following areas of our platform: - Cloud Point of Sale - Back Office - Any website using Cloudflare - Cloud MT - Courier Integration - Customer Rewards
This issue is being investigated as our top priority and further updates will be provided as soon as possible.
Posted Jul 15, 2026 - 14:53 BST
This incident affected: Cloud POS, eCommerce Platform - Standard, eCommerce Platform - Premium, CloudMT, Customer Rewards, and Courier Integration Module.